2018-04-25 00:48 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004781Talertwisterpublic2018-04-15 20:37
ReporterMarcello Stanisci 
Assigned ToMarcello Stanisci 
PrioritynormalSeverityfeatureReproducibilityhave not tried
StatusresolvedResolutionfixed 
Product VersionSVN HEAD 
Target Version0.6Fixed in Version0.6 
Summary0004781: Error generating MITM
DescriptionWe need a software layer that proxies requests between Taler components, and alters their
payload in order to test how Taler reacts to errors.

The layer is a HTTP service whose behaviour can be driven via ad-hoc HTTP headers.
TagsNo tags attached.
Attached Files

-Relationships Relation Graph ] Dependency Graph ]
duplicate of 0004186resolvedMarcello Stanisci fault injection should be implemented 
child of 0004454resolvedMarcello Stanisci fault injection for all GNU Taler APIs 
+Relationships

-Notes

~0012814

Christian Grothoff (manager)

Twister repository and foundations now exist.

~0012897

Marcello Stanisci (manager)

As of 2e773e85b59bdf8dc2c52 (twister.git), this component
can be considered usable. Other bugs can be reported in dedicated
filings.
+Notes

-Issue History
Date Modified Username Field Change
2016-11-13 21:04 Marcello Stanisci New Issue
2017-03-18 23:57 Christian Grothoff Severity minor => feature
2017-03-18 23:57 Christian Grothoff Status new => confirmed
2017-03-18 23:58 Christian Grothoff Product Version => SVN HEAD
2017-03-29 00:25 Marcello Stanisci Assigned To => Marcello Stanisci
2017-03-29 00:25 Marcello Stanisci Status confirmed => assigned
2017-04-27 14:18 Marcello Stanisci Description Updated View Revisions
2017-04-30 13:32 Marcello Stanisci Relationship added parent of 0004930
2018-01-15 15:59 Christian Grothoff Relationship added child of 0004454
2018-01-15 21:14 Christian Grothoff Relationship added duplicate of 0004186
2018-01-20 18:57 Christian Grothoff Category deployment and operations => twister
2018-01-20 18:57 Christian Grothoff Note Added: 0012814
2018-03-27 11:41 Marcello Stanisci Note Added: 0012897
2018-03-27 11:43 Marcello Stanisci Relationship deleted parent of 0004930
2018-03-27 11:48 Marcello Stanisci Status assigned => resolved
2018-03-27 11:48 Marcello Stanisci Resolution open => fixed
2018-04-15 20:35 Christian Grothoff Fixed in Version => 0.5
2018-04-15 20:36 Christian Grothoff Status resolved => closed
2018-04-15 20:37 Christian Grothoff Status closed => resolved
2018-04-15 20:37 Christian Grothoff Fixed in Version 0.5 => 0.6
+Issue History